package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\d.]+)\s([\d.]+)\s([\d.]+)\s([\d.]+)\s([\d.]+)`)
var str = `104.99 0.00 0.00 0.00 0.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}