$re = '/^[^\d][A-Za-z0-9]+/m';
$str = '123abc
abc123abc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);