re = /(?<=xmlUrl=")[^"]*/i
str = '<outline type="rss" text="Tech Viral" title="Tech Viral" xmlUrl="http://feeds.feedburner.com/TechViral" htmlUrl="https://techviral.net"/>
<outline type="rss" text="The Verge" title="The Verge" xmlUrl="http://www.theverge.com/rss/full.xml" htmlUrl="https://www.theverge.com/"/>
<outline type="rss" text="Joystiq" title="Joystiq" xmlUrl="http://www.joystiq.com/rss.xml" htmlUrl="https://www.engadget.com/rss.xml"/>
<outline type="rss" text="BGR" title="BGR" xmlUrl="http://www.boygeniusreport.com/feed/" htmlUrl="http://bgr.com"/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end