package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+\d{2,4})?\s?(\d{2,4}|\(\d{2,4}\))?\s?[\d\s.-]{3,15}$`)
var str = `9999 99999-99
+99 999288432
(883) 892739723
+12 123 8293-76.238
123 234 879347-837`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}