const regex = /^(\+\d{2,4})?\s?(\d{2,4}|\(\d{2,4}\))?\s?[\d\s.-]{3,15}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+\\d{2,4})?\\s?(\\d{2,4}|\\(\\d{2,4}\\))?\\s?[\\d\\s.-]{3,15}$', 'gm')
const str = `9999 99999-99
+99 999288432
(883) 892739723
+12 123 8293-76.238
123 234 879347-837`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}