re = /^(\+\d{2,4})?\s?(\d{2,4}|\(\d{2,4}\))?\s?[\d\s.-]{3,15}$/m
str = '9999 99999-99
+99 999288432
(883) 892739723
+12 123 8293-76.238
123 234 879347-837'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end