const regex = /(\bPlease\b)(?!.*\1)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\bPlease\\b)(?!.*\\1)', 'gm')
const str = `This email is unabliabe. Please "sent fdfds;lfk"
This email is send. "Please" sent f;dlskf
This email have been send to you. Please Please fdsfsf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}