import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z]{3}\\d{3})\\s([a-zA-Z]{9}\\s+\\((\\d{4})\\)\\s+\\*[a-zA-Z]{3})\\s+([a-zA-Z]+\\d\\w)\\s+\\.([a-zA-Z]+)\\s(\\d+)\\s+";
final String string = " LMZ333 ALLOTMENT (0000) *TSC \n"
+ "HDQRM5I \n"
+ ".MADRIIB 160846 \n"
+ "MADIB N4MPK/HELIB0150/1949417/HEL/IB/A/FI//RC//\n"
+ "HDQ5I N4MPK\n"
+ "1CUVILEON/CARLOS EDUARDO\n"
+ "1CONTRERASARNAEZ/MARIA BEGONA 1ROBLEDOCONTRERAS/PATRICIA \n"
+ "5I8397J/IB2198J25JUN RZGMAD CS1/0850 1220\n"
+ "5I8327J/IB2194J06JUL MADRZG CS1/1745 2115\n"
+ "OSI 5I CTCP 34606686051-M\n"
+ "OSI 5I POSI-DSAC//MADIB08AB/I/1\n"
+ "OSI 5I CARLOSCUVILIN//GMAIL.COM\n"
+ "= ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}