import re
regex = re.compile(r"((.*\|.*\|.*)+([\n\r]|.*))+", flags=re.MULTILINE)
test_str = ("Colons can be used to align columns.\n\n"
"| Tables | Are | Cool |\n"
"| ------------- |:-------------:| -----:|\n"
"| col 3 is | right-aligned | $1600 |\n"
"| col 2 is | centered | $12 |\n"
"| zebra stripes | are neat | $1 |\n\n"
"There must be at least 3 dashes separating each header cell.\n"
"The outer pipes (|) are optional, and you don't need to make the \n"
"raw Markdown line up prettily. You can also use inline Markdown.\n\n"
"Markdown | Less | Pretty\n"
"--- | --- | ---\n"
"*Still* | `renders` | **nicely**\n"
"1 | 2 | 3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")