$re = '/^(Abstract|Base)[A-Z][a-zA-Z0-9]*$/m';
$str = 'AbstractClass
BaseClass
AbstractT
AbstractPerson';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);