using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[^=])=(?=[^=])(?=(?:[^\']*\'[^\']*\')*[^\']*$)";
string input = @"age=10 and address='a==c=d' and age==100 and abc = 22";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}