// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:1\d|[1-9])?\d|2(?:[0-4]\d|5[0-5]))(?:\.(?1)){3}$").unwrap();
let string = "Must match
----------
10.9.0.77
172.30.249.8
192.0.2.84
192.168.29.165
224.255.0.31
Must not match
--------------
10.09.00.77
172.030.249.008
192.0.02.084
224.256.0.31";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}