package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`NWD[0-9]+ PADRAO -`)
var str = `NWD0 PADRAO -", "NWD1 PADRAO -", "NWD2 PADRAO -"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}