re = /NWD[0-9]+ PADRAO -/
str = 'NWD0 PADRAO -", "NWD1 PADRAO -", "NWD2 PADRAO -"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end