// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"NWD[0-9]+ PADRAO -").unwrap();
let string = "NWD0 PADRAO -\", \"NWD1 PADRAO -\", \"NWD2 PADRAO -\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}