const regex = /[1-3][a-f]{5}_.*<IP>.*\tp\ta\ts\ts/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[1-3][a-f]{5}_.*<IP>.*\\tp\\ta\\ts\\ts', 'gm')
const str = `2abcde_123<IP>32131 p a s s`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}