const regex = new RegExp('(?i)^(?:foo|bar) (?:(?:[a-z\\d\\'.-](?<![\\'.-]{2})){1,7} ){1,5}\\w{1,7}$', 'gm')
const str = `foo Brian M. O'Dan Darwin
foo Brian M.. ODan Darwin
foo Brian M. O'-Dan Darwin
foo Brian M. O'Dan Darwin`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}