$re = '/<img.*src=\'?"?(.*?)\'?"?\/?>/m';
$str = '<img src="http://abc.png">
<img src=\'http://abc.png\'>
<img src=\'https://abc.png\'>
<img src=\'http://abc.png\'/>
<img src=\'http://abc.jpg\'>
<img class="abc" src=\'http://abc.jpeg\'>
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;