re = /<img.*src='?"?(.*?)'?"?\/?>/m
str = '<img src="http://abc.png">
<img src=\'http://abc.png\'>
<img src=\'https://abc.png\'>
<img src=\'http://abc.png\'/>
<img src=\'http://abc.jpg\'>
<img class="abc" src=\'http://abc.jpeg\'>
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result