$re = '/(?<name>.+?)[\r\n](?<datetime>.+?)[\r\n](Region: +(?<region>.*)[\r\n]Generated By: +(?<generatedBy>.*)[\r\n]((?<xommands>.+?)[\r\n])*?(?=.+?[\r\n].+?[\r\n]Region))*/m';
$str = 'The Insurance Place Agency, LLC
2018/12/26 22:26:07
Region: null
Generated By: jmainer
New-HSAgency -AgencyName \'\'00018097\'\'
New-HSAgencyGPO -AgencyName \'\'00018097\'\'
New-HSUser -UserName \'\'18097_username\'\' -FirstName \'\'User\'\' -LastName \'\'Name\'\' -AgencyName \'\'00018097\'\' -Password \'\'LHdfzJYJOwH5\'\'
The Insurance Place Agency, LLC
2018/12/26 22:26:07
Region: null
Generated By: jmain222er
New-HSAgency -AgencyName \'\'00018097\'\'
New-HSAgencyGPO -AgencyName \'\'00018097\'\'
New-HSUser -UserName \'\'18097_username\'\' -FirstName \'\'User\'\' -LastName \'\'Name\'\' -AgencyName \'\'00018097\'\' -Password \'\'LHdfzJYJOwH5\'\'
The Insurance Place Agency, LLC
2018/12/26 22:26:07
Region: null
Generated By: jmainer
New-HSAgency -AgencyName \'\'00018097\'\'
New-HSAgencyGPO -AgencyName \'\'00018097\'\'
New-HSUser -UserName \'\'18097_username\'\' -FirstName \'\'User\'\' -LastName \'\'Name\'\' -AgencyName \'\'00018097\'\' -Password \'\'LHdfzJYJOwH5\'\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);