# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*\b(?!N=\d)\w+=\d+//gm;t' <<< "P=32 N=5 M=2"