use strict;
my $str = 'P=32 N=5 M=2';
my $regex = qr/\s*\b(?!N=\d)\w+=\d+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";