using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(domain.com|domain1.com)";
string input = @"domain.com
domain1.com
ci.domain1.com";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}