$re = '/^1\h+(?=\d(?:[^\d\n\r]?\d){9}$)/m';
$str = '1 800-555-1111
1 222-555-1111
888-555-1111
1 888 555 1111
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;