package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(ATK 30)\s*`)
var str = `Product desingATK 30Trace back. TheATK 30 is a nice device. `
var substitution = " \1 "
fmt.Println(re.ReplaceAllString(str, substitution))
}