using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\s)((\d*\.?\d*)*|([+*^\.\(\)\-])*?)?";
string input = @"This one works for value.match() in JS
/(?!\s)(([+\-*^()])|(\d*\.?\d*)*)/gm
The one in the bar shows how it collects the values
7 + 5
7+ 5
7 +5
5 + 7
6 * 5
6 ^ 5
6 - 5
(60 + 5) * 4
( 70 + 5) + 4
+4
*657
(*6)
7.6656
( 6.54 + 5) * 33.4
+-^*()00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}