use strict;
my $str = 'This one works for value.match() in JS
/(?!\\s)(([+\\-*^()])|(\\d*\\.?\\d*)*)/gm
The one in the bar shows how it collects the values
7 + 5
7+ 5
7 +5
5 + 7
6 * 5
6 ^ 5
6 - 5
(60 + 5) * 4
( 70 + 5) + 4
+4
*657
(*6)
7.6656
( 6.54 + 5) * 33.4
+-^*()00';
my $regex = qr/(?!\s)((\d*\.?\d*)*|([+*^\.\(\)\-])*?)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}