#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "All files[^|]*\|[^|]*\s+([\d\.]+)"
Local $sString = "---------------------|----------|----------|----------|----------|----------------|" & @CRLF & _
"File | % Stmts | % Branch | % Funcs | % Lines |Uncovered Lines |" & @CRLF & _
"---------------------|----------|----------|----------|----------|----------------|" & @CRLF & _
"[32;1mAll files [0m |[32;1m 85.61[0m |[33;1m 59.85[0m |[32;1m 84.06[0m |[32;1m 87.14[0m |[31;1m [0m |" & @CRLF & _
"[32;1m cli [0m |[32;1m 95.37[0m |[33;1m 70.21[0m |[33;1m 76.47[0m |[32;1m 97.12[0m |[31;1m [0m |" & @CRLF & _
"[32;1m add.js [0m |[32;1m 100[0m |[32;1m 83.33[0m |[32;1m 100[0m |[32;1m 100[0m |[33;1m 12[0m |" & @CRLF & _
"" & @CRLF & _
"---------------------|----------|----------|----------|----------|----------------|" & @CRLF & _
"File | % Stmts | % Branch | % Funcs | % Lines |Uncovered Lines |" & @CRLF & _
"---------------------|----------|----------|----------|----------|----------------|" & @CRLF & _
"All files | 85.61 | 59.85 | 84.06 | 87.14 | |" & @CRLF & _
" cli | 95.37 | 70.21 | 76.47 | 97.12 | |" & @CRLF & _
" add.js | 100 | 83.33 | 100 | 100 | 12 |" & @CRLF & _
" adduser.js | 100 | 83.33 | 100 | 100 | 21,23 |" & @CRLF & _
" new.js | 100 | 75 | 100 | 100 | 18,20 |"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")