using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Za-z0-9]\w+\s\w+)+";
string input = @"Fares Alarabi Ahmed Algamdi Ibrahim Halawi Hossam Almalki Meshal Alshehri Mesleh Almansori Basel Almeshari Mohammed Alkhalifah ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}