package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Za-z0-9]\w+\s\w+)+`)
var str = `Fares Alarabi Ahmed Algamdi Ibrahim Halawi Hossam Almalki Meshal Alshehri Mesleh Almansori Basel Almeshari Mohammed Alkhalifah `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}