#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mxs)(?(DEFINE)" & @CRLF & _
" (?P<date>\d{2}/\d{2}/\d{2},\ \d{2}:\d{2})" & @CRLF & _
")" & @CRLF & _
"^" & @CRLF & _
"(?&date)" & @CRLF & _
"(?:(?!^(?&date)).)+"
Local $sString = "27/08/15, 15:45 - text" & @CRLF & _
"continue text" & @CRLF & _
"continue text 2" & @CRLF & _
"27/08/15, 16:10 - new text" & @CRLF & _
"new text 2" & @CRLF & _
"new text 3" & @CRLF & _
"27/08/15, 19:55 - more text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")