$re = '~(?(DEFINE)
(?P<date>\d{2}/\d{2}/\d{2},\ \d{2}:\d{2})
)
^
(?&date)
(?:(?!^(?&date)).)+~mxs';
$str = '27/08/15, 15:45 - text
continue text
continue text 2
27/08/15, 16:10 - new text
new text 2
new text 3
27/08/15, 19:55 - more text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);