#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(ucode|cryptsetup|linux|nvidia|mesa|systemd|wayland|xf86-video|xorg|firefox)"
Local $sString = "firefox 79.0-1 -> 80.0-1" & @CRLF & _
"jasper 2.0.17-1 -> 2.0.19-1" & @CRLF & _
"partclone 0.3.12-1 -> 0.3.15-1" & @CRLF & _
"sqlite 3.32.3-1 -> 3.33.0-1" & @CRLF & _
"sublime-merge 2030-1 -> 2031-1" & @CRLF & _
"talloc 2.3.1-2 -> 2.3.1-3" & @CRLF & _
"xterm 358-1 -> 359-1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")