import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^#TR\\|\\d+[^\\t]+\\tIdentifier\\|\\d+[^\\t]+\\t(FC\\d+)\\/(\\d+)";
final String string = "#TR|1 Normal Identifier|2 Normal FC0018724/001\n"
+ "#TR|1 Normal Identifier|2 Normal FC0013224/001\n"
+ "#TR|1 Normal Identifier|2 Normal FC001111113/001\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}