// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^#TR\|\d+[^\t]+\tIdentifier\|\d+[^\t]+\t(FC\d+)\/(\d+)").unwrap();
let string = "#TR|1 Normal Identifier|2 Normal FC0018724/001
#TR|1 Normal Identifier|2 Normal FC0013224/001
#TR|1 Normal Identifier|2 Normal FC001111113/001
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}