import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\\.[0-9][0-9\\(\\)\\/:\\s]{20},\\s([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\\.[0-9][0-9\\(\\)\\/:\\s]{20},\\s([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\\.[0-9][0-9\\(\\)\\/:\\s]{20}\\]";
final String string = "[118.0 (09/01/23 17:08:00), 216.0 (09/01/23 17:07:00), 88.0 (09/01/23 17:06:00)]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}