const regex = /(?:(?<=[^\p{L}\p{N}])|^)42(?=[^\p{L}\p{N}]|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<=[^\\p{L}\\p{N}])|^)42(?=[^\\p{L}\\p{N}]|$)', 'g')
const str = `42
hello 42
hello-42-
été42
042
4 2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}