re = /(?:(?<=[^\p{L}\p{N}])|^)42(?=[^\p{L}\p{N}]|$)/
str = '42
hello 42
hello-42-
été42
042
4 2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end