package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:.*.)*?Amber=>HI3.Amber`)
var str = `Golden Deer Students (Fire Emblem)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}