$re = '/(?:.*.)*?Amber=>HI3.Amber/m';
$str = 'Golden Deer Students (Fire Emblem)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);