#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<figure[^>]*>[^>]*<img[^>]*src\s*=\s*"\K(.*?)(?=" \/>)"
Local $sString = "<img src="lorem.png" />" & @CRLF & _
"" & @CRLF & _
"<figure><img alt="" src="test-image-1.png" /><figcaption>test caption</figcaption></figure>" & @CRLF & _
"" & @CRLF & _
"<figure><img alt="" src="test-image-2-png" /><figcaption>test caption 2</figcaption></figure>" & @CRLF & _
"" & @CRLF & _
"<img src="ipsum.png />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")