using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<figure[^>]*>[^>]*<img[^>]*src\s*=\s*""\K(.*?)(?="" \/>)";
string input = @"<img src=""lorem.png"" />
<figure><img alt="" src=""test-image-1.png"" /><figcaption>test caption</figcaption></figure>
<figure><img alt="" src=""test-image-2-png"" /><figcaption>test caption 2</figcaption></figure>
<img src=""ipsum.png />";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}