const regex = /<figure[^>]*>[^>]*<img[^>]*src\s*=\s*"\K(.*?)(?=" \/>)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<figure[^>]*>[^>]*<img[^>]*src\\s*=\\s*"\\K(.*?)(?=" \\\/>)', 'gms')
const str = `<img src="lorem.png" />
<figure><img alt="" src="test-image-1.png" /><figcaption>test caption</figcaption></figure>
<figure><img alt="" src="test-image-2-png" /><figcaption>test caption 2</figcaption></figure>
<img src="ipsum.png />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}