import Foundation
let pattern = #"<figure[^>]*>[^>]*<img[^>]*src\s*=\s*"\K(.*?)(?=" \/>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
<img src="lorem.png" />
<figure><img alt="" src="test-image-1.png" /><figcaption>test caption</figcaption></figure>
<figure><img alt="" src="test-image-2-png" /><figcaption>test caption 2</figcaption></figure>
<img src="ipsum.png />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)