import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:2[0-3]|[01]\\d|\\d):[0-5]\\d$";
final String string = "10:30\n"
+ "18:15\n"
+ "6:24\n"
+ "44:99\n"
+ "00:19\n"
+ "00:00\n"
+ "24:59\n"
+ "23:59\n"
+ "1:12\n"
+ "1:60\n"
+ "13:42";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}