const regex = new RegExp('^(?:2[0-3]|[01]\\d|\\d):[0-5]\\d$', 'gm')
const str = `10:30
18:15
6:24
44:99
00:19
00:00
24:59
23:59
1:12
1:60
13:42`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}