using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]{5}\s(\D+)";
string input = @"2 pièces - Rue Davioud 75016 Paris
2 pièces - Rue des Tilleuls 92100 Boulogne-Billancourt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}