import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.{0,2}(你知道)?#有?(什么|啥)(好?(吃的|食物)|((东西|玩意)?好吃))(吗|么|嘛|不)?$";
final String string = "#有什么好吃的\n"
+ "#有啥好吃的\n"
+ "#啥好吃\n"
+ "#什么玩意好吃\n"
+ "#啥东西好吃\n"
+ "去#吃啥\n"
+ "到#吃什么好吃的\n"
+ "去#应该吃啥";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}