import re
regex = re.compile(r"^.{0,2}(你知道)?#有?(什么|啥)(好?(吃的|食物)|((东西|玩意)?好吃))(吗|么|嘛|不)?$", flags=re.MULTILINE)
test_str = ("#有什么好吃的\n"
"#有啥好吃的\n"
"#啥好吃\n"
"#什么玩意好吃\n"
"#啥东西好吃\n"
"去#吃啥\n"
"到#吃什么好吃的\n"
"去#应该吃啥")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")