const regex = new RegExp('((((о|е|ё)(в|ц)а?)|((ы|и)на?))|(о|а(й|к|у|ч)?)|(к((о|и)й|ая))|(и(ч|ц))|((ы|и)(х|й)|ая)|((у|ю|о)(к|н|б))|(штейн|манн?|сон))\\b', 'gm')
const str = `Смирнов/Cмиров
Николаев/Николаева
Никитин/Никитина
Киселёв/Киселёва
Пятницын/Пятницына
Крыленко
Хованский/Хованская
Калита
Шемяка
Донской/Донская
Теплых
Усович
Царук
Нагорный/Нагорная
Деньнуб
Заренок
Шевчук
Драгун
Харинтон
Горбатых
Фидорец
Слободенюк
Кравчук
Голицын
Лифшиц
Либерман
Капица
Айнштейн
Лазерсон
Байдачный/Байдачная
Зварыкин/Зварыкина
Коллонтай
Cобчак
Ландау
Василец
Кучерявый
Бородач
Грицюк
Радаев
Белаец
Деев
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}